Spis treści

Opis programu
Okno główne
Ustawienia projektu
Ustawienia wyglądu generowanego sklepu internetowego
Zarządzanie projektami
Tworzenie nowego projektu
Otwieranie istniejącego projektu
Zapis istniejącego projektu
Instrukcje krok po kroku
Tworzenie sklepu internetowego
Wysyłanie sklepu na serwer WWW
Inne
Opis dostępnej funkcjonalności programu
Najczęściej zadawane pytania
Wymagania sprzętowe

Warunki licencyjne

Dane kontaktowe


Okno główne

Spis elementów okna głównego:

  1. Pełne menu aplikacji.
  2. Menu z głównymi opcjami w postaci ikon.
  3. Panel ze zdefiniowanymi kategoriami wraz z menu służącym do tworzenia/modyfikacji/usuwania kategorii i podkategorii.
  4. Panel zawierający zestawienie produktów w postaci tabelarycznej.
  5. Panel zawierający szczegółowe informacje wybranego produktu wraz z menu umożliwiającym operacje na produktach.

Opis szczegółowy
1. Pełne menu aplikacji

Menu to jest złożone z następujących grup poleceń:
  • Projekt – operacje na projekcie (tworzenie nowego/wczytywanie/zapisywanie) oraz zamknięcie aplikacji,
  • Kategorie – operacje na kategoriach (dodawanie/usuwanie kategorii, dodawanie/usuwanie podkategorii),
  • Produkty – operacje na produktach (dodawanie/usuwanie/edycja),
  • Ustawienia – definiowanie wyglądu generowanego sklepu oraz sposobu wprowadzania danych.
2. Menu z podstawowymi opcjami programu w postaci ikon
Opis dostępnych przycisków:
Przycisk | Opis
 | Ustawienia projektu
 | Ustawienia wyglądu generowanej strony WWW
 | Generowanie strony WWW dla bieżącego projektu
 | Wysłanie wygenerowanej strony WWW na serwer FTP
 | Wyświetlanie aktualnie wygenerowanej strony w domyślnej przeglądarce WWW
3. Panel kategorii.
Panel ten składa się z dwóch zawsze widocznych części, tj.:
  • Lista kategorii – zawiera ona poza kategoriami towarów wprowadzonymi przez użytkownika, także kategorie systemowe (strona główna /pokaż koszyk zamawiaj). Kategorie te pojawiają się w celu przybliżenia wyglądu generowanej strony także podczas wprowadzania danych,
  • Menu podręcznego – tutaj znajdują się wszelkie opcje dotyczące operacji na kategoriach,

oraz części widocznej opcjonalnie, a pokazującej się podczas edycji lub wprowadzaniu nowej kategorii, i zawierającej:

  • Nazwę,
  • Opis kategorii - gdy opis jest niepusty to pojawia się on na generowanej stronie,
  • (*) Dostępność właściwości - tutaj określamy czy zdefiniowana wcześniej właściwość użytkownika ma być wyświetlana dla produktów w edytowanej kategorii. Domyślnie wszystkie właściwości użytkownika są wyświetlane we wszystkich kategoriach. Jednak odznaczenie przycisku w kolumnie 'Dostępność' na tej zakładce spowoduje iż właściwość ta nie będzie uwzględniana w tej kategorii.
    Zobacz Definiowanie właściwości użytkownika.

Opis przycisków menu podręcznego:

Przycisk | Opis | Dostępność
 | Dodawanie nowej kategorii (podkategorii) na aktualnie wybranym poziomie | Dostępna zawsze
 | Dodawanie podkategorii dla aktualnie wybranej kategorii w menu | Dostępne gdy wybrana jest kategoria użytkownika.
 | Przesunięcie wyżej aktualnie wybranej kategorii. (przesunięcie następuje razem z podkategoriami) | Dostępne gdy na tym samym poziomie istnieje wyżej kategoria użytkownika
 | Przesunięcie niżej aktualnie wybranej kategorii. (przesunięcie następuje razem z podkategoriami) | Dostępne gdy na tym samym poziomie istnieje niżej kategoria użytkownika
 | Usunięcie aktualnie wybranej kategorii | Dostępne gdy wybrano kategorię wprowadzoną przez użytkownika
 | Edycja aktualnie wybranej kategorii | Dostępne gdy wybrano kategorię wprowadzoną przez użytkownika
 | Zatwierdzenie utworzenia nowej kategorii lub zmiany jej nazwy | Dostępna gdy wprowadzamy nową lub edytujemy istniejącą kategorię
 | Anulowanie zmiany nazwy kategorii | Dostępna gdy wprowadzamy nową lub edytujemy istniejącą kategorię

Uwaga:

Dodawanie nowej kategorii (podkategorii), jest procesem dwu stopniowym. W pierwszym kroku użytkownik pytany jest o nazwę. Po jej wprowadzeniu program przechodzi do trybu edycji tak aby możliwe było uzupełnienie opisu oraz korekta wprowadzonej nazwy. Po uzupełnieniu powyższych informacji zmiany należy zatwierdzić.
4. Panel zawierający zestawienie produktów w postaci tabelarycznej
Panel ten zawiera w zależności od ustawień zestawienie produktów ze wszystkich dostępnych kategorii lub tylko z aktualnie wybranej.

Zestawienie zawiera:

  • ID produktu,
  • Kategoria,
  • Nazwa,
  • Producent,
  • Cena.
5. Panel szczegółów produktu
Panel ten wyświetla informacje o aktualnie wybranym produkcie na liście. Ponieważ wszystkie informacje nie mieszczą się jednocześnie na oknie to został on podzielony na zakładki. (Dane ogólne/ Opis/ (*)Właściwości użytkownika/ (*)Promocje)

W celu ułatwienia obsługi produktów pod oknem szczegółów pozycji znajduje się pasek przycisków funkcyjnych. Opis dostępnych przycisków:

Przycisk | Opis | Dostępność
 | Dodanie nowego produktu w aktualnie wybranej kategorii | Dostępne gdy wybrana jest kategoria użytkownika
 | Usunięcie aktualnie wybranego produktu | Dostępne gdy wybrana jest pozycja w panelu produktów
 | Edycja aktualnie wybranego produktu | Dostępne gdy wybrana jest pozycja w panelu produktów
 | Zapisanie zmian w produkcie | Dostępne gdy wstawiamy lub edytujemy produkt
 | Anulowanie zmian wprowadzonych podczas aktualnej modyfikacji/wstawiania produktu | Dostępne gdy wstawiamy lub edytujemy produkt
 | Dodanie zdjęcia produktu | Dostępne gdy wstawiamy lub edytujemy produkt
 | Pokazanie zdjęcia produktu w osobnym oknie | Dostępne gdy produkt ma przypisane zdjęcie
 | Usunięcie zdjęcia produktu | Dostępne gdy produkt jest wstawiany lub edytowany i zostało już mu przypisane jego zdjęcie
 | Dodanie zdjęcia promocyjnego produktu | Dostępne gdy wstawiamy lub edytujemy produkt. (*)
 | Pokazanie zdjęcia promocyjnego produktu w osobnym oknie. | Dostępne gdy produkt ma przypisane zdjęcie. (*)
 | Usunięcie zdjęcia promocyjnego produktu | Dostępne gdy produkt jest wstawiany lub edytowany i zostało już mu przypisane jego zdjęcie. (*)

Opis zakładek:

  1. Dane ogólne: Uzupełniamy tutaj podstawowe informacje o produkcie takie jak: nazwa, kategoria, cena, zdjęcie. Ponadto mamy do dyspozycji jedno definiowalne pole dodatkowe w którym możemy przechowywać dowolną informację o produkcie. Zobacz Definiowanie podstawowej właściwości użytkownika. Dodatkowe ustawienia:
    1. 'pomijaj przy generowaniu sklepu' - włączenie tej opcji powoduje nie wyświetlanie produktu w generowanym sklepie, produkt ten pozostaje jednak w naszej bazie danych. Przykład: gdy produkt nie będzie dostępny tymczasowo w sprzedaży wystarczy zaznaczyć tą opcję a nie pojawi się w generowanym sklepie. Gdy produkt ponownie będzie dostępny wystarczy odznaczyć tą opcję a ponownie zostanie on uwzględniony przy generowaniu sklepu.
    2. 'niedostępna sprzedaż' - włączenie tej opcji spowoduje, że w żadnym zestawieniu przy produkcie nie pojawi się przycisk dodawania do koszyka. Opcja ta jest pożyteczna gdy sprzedaż jest niemożliwa np. z powodu chwilowego braku towaru, i chcemy aby pomimo tego produkt pojawiał się w sklepie.
  2. Opis: Opis produktu.
  3. (*) Właściwości użytkownika: Zakładka ta jest dostępna w zależności od wersji i umożliwia uzupełnianie dowolnie zdefiniowanych przez użytkownika właściwości produktu, np. waga, rozmiar, data produkcji, itd… Zobacz Definiowanie właściwości użytkownika.
  4. (*) Promocje: Zakładka ta jest dostępna w zależności od wersji programu i umożliwia definiowanie informacji o promocji danego produktu. Opis pól:
    1. Nazwa skrócona: Nazwa produktu wyświetlana w tytule produktu. Nazwa ta może mieć maksymalnie 20 znaków.
    2. Dodatkowa informacja 1: Dowolny tekst umieszczony w pierwszej linii pod zdjęciem produktu. Pole nie jest wyświetlane gdy nie wprowadzono tekstu przy produkcie.
    3. Dodatkowa informacja 2: Dowolny tekst umieszczony w drugiej linii pod zdjęciem produktu. Pole nie jest wyświetlane gdy nie wprowadzono tekstu przy produkcie.
    4. Stara cena: Cena, która obowiązywała przed promocją. (Nazwa ‘Stara cena’ jest definiowalna w ustawieniach projektu). Pole to wyświetlane jest zawsze i jeśli było nie uzupełnione to domyślną wartością będzie 0.00.
    5. Rodzaj promocji: W tym polu definiujemy czy dany towar ma być objęty promocją a jeśli tak to jakiego rodzaju ma być to promocja. Dostępne wartości:
      1. Brak: Produkt nie jest objęty promocją.
      2. Super oferta: Produkt jest objęty promocją typu ‘Super oferta’ tzn., że wyświetlany jest on u samej góry listy promocyjnej i widoczny jest we wszystkich kategoriach i podkategoriach, oraz przy szczegółach każdego z produktów.
      3. Promocja w kategorii: Produkt objęty tego typu promocją dostępny jest pod produktami typu ‘Super oferta’ i widoczny jest on tylko wtedy gdy wyświetlana jest kategoria do której on należy lub szczegóły jednego z produktów tej kategorii.
      4. Promocja w kategorii i podkategoriach: Produkt objęty tego typu promocją dostępny jest pod produktami typu ‘Super oferta’ i widoczny jest on tylko wtedy gdy wyświetlana jest kategoria do której on należy (lub jedna z jej podkategorii), albo też szczegóły jednego z produktów należących do tych kategorii.
    6. Zdjęcie: Miniaturka zdjęcia produktu widoczne przy promocji.

(*) - oznacza, że opcje te występują tylko w niektórych wersjach. { Szczegółowy opis funkcjonalności z podziałem na wersje…}


Ustawienia projektu

Okno to służy do:
* definiowania jakie operacje są dozwolone na kategoriach oraz produktach podczas ich wprowadzania/edytowania/usuwania. (zakładka Kategorie/Produkty)
* definiowania parametrów serwera na, którym przechowywany jest dany sklep internetowy.
1. Zakładka Ogólne
W tym miejscu definiujemy podstawowe dane dotyczące projektu.

Nazwa projektu zawiera nazwę, którą chcemy przypisać aktualnemu projektowi.

Opcje dotyczące kategorii

  • ‘pozwalaj zmieniać nazwę tylko kategoriom nie zawierającym produktów’ – jeśli ta opcja jest włączona to nie można zmienić nazwy kategorii gdy przypisany jest do niej jakiś produkt oraz gdy kategoria ta zawiera podkategorię z przypisanym do niej produktem. Gdy opcja ta jest wyłączona powyższe operacje są możliwe. Ponadto uaktywniana jest opcja ‘przy zmianie nazwy kategorii uaktualniaj informację o produktach’,
  • ‘przy zmianie nazwy kategorii uaktualniaj informację o produktach’ – opcja dostępna gdy wyłączono ustawienie pozwalające zmieniać nazwę tylko kategoriom nie zawierającym produktów. Gdy opcja ta jest włączona to podczas zmiany nazwy kategorii modyfikowana jest także informacja o kategorii pochodzenia wszystkich produktów zawartych w tej kategorii i we wszystkich podkategoriach modyfikowanej kategorii,
  • ‘pozwalaj usuwać tylko kategorie nie zawierające podkategorii’ - jeśli ta opcja jest włączona to nie można usunąć kategorii, która zawiera jakąkolwiek podkategorię. (pustą/albo też nie). Gdy opcja ta jest wyłączona to usuwana jest cała kategoria razem z istniejącymi podkategoriami, przy czym jeśli włączona jest opcja ‘pozwalaj usuwać tylko kategorie bez produktów’ to usuwanie jest możliwe jeśli o ile ani ta kategoria ani też żadna z podkategorii, które zawiera nie mają przypisanych produktów,
  • ‘pozwalaj usuwać tylko kategorie bez produktów’ – jeśli ta opcja jest włączona to nie można usunąć kategorii, która zawiera jakikolwiek produkt lub zawiera podkategorię zawierającą produkt. Gdy opcja jest wyłączona to możliwość usuwania zleży od ustawienia opcji ‘pozwalaj usuwać tylko kategorie nie zawierające podkategorii’.

Opcje dotyczące produktów

  • ‘pokazuj produkty tylko z wybranej kategorii’ – włączenie tej opcji powoduje, że w aplikacji podczas definiowania produktów pojawią się tylko produkty z tej kategorii natomiast pozostałe są ukryte,
  • Opcje sortowania ustawiają w jakiej kolejności odbywa się sortowanie na oknie. Ustawienia sortowania dotyczą także zestawień tabelarycznych na generowanych stronach internetowych.
2. Zakładka Parametry serwera
W tym miejscu definiujemy parametry serwera FTP na który wysyłane mają być wygenerowane strony internetowe, takie jak nazwa serwera, użytkownik, hasło oraz katalog zdalny na serwerze na który ma być wysłany wygenerowany sklep.

Uwaga:

  • Jeśli katalog zdalny nie istnieje na serwerze to transfer plików nie powiedzie się.
  • Jeśli użytkownik wprowadził nieprawidłowe parametry FTP to podczas wysyłania program poprosi o ich poprawienie, przy czym zmiany tam wprowadzone nie zostaną zapamiętane w programie głównym.
3. Właściwości podstawowe

Zakładka ta składa się z następujących grup ustawień

  • Nazwy właściwości
    • Pole dodatkowe – nazwa pola dodatkowego, która pojawi się na wygenerowanej stronie, może to być np. producent (domyślnie), numer katalogowy, czy też dowolna inna wartość pasującą do sprzedawanego asortymentu,
    • Pole ceny – nazwa pola z ceną, np. cena (domyślnie), cena brutto, nowa cena, itd…
  • (*) Wyrównywanie (zestawienie tabelaryczne) - tutaj określamy sposób wyrównywania właściwości podstawowych w zestawieniu tabelarycznym. Dostępne wartości to brak wyrównywania, do lewej, środkowanie i do prawej. Gdy nie przypiszemy wyrównywania to sposób wyświetlania zostanie narzucony przez domyślne ustawienie przeglądarki internetowej.
  • (*) Widoczność właściwości - tutaj określamy czy właściwość podstawowa ma być wyświetlana.
    • 'pokazuj pole dodatkowe' - opcja ta jest odpowiedzialna za wyświetlanie 'pola dodatkowego' na zestawieniach. Jej zaznaczenie powoduje, że właściwość ta jest widoczna zarówno w zestawieniu tabelarycznym jak i też szczegółowym, natomiast po odznaczeniu nie jest ona widoczna na żadnym z powyższych zestawień.
    • 'pokazuj ID produktu' - jak wyżej, tyle że dotyczy automatycznie generowanego ID produktu.
    • 'pokazuj opis' - włączenie tej opcji powoduje, że do zestawienia szczegółowego dołączany jest opis produktu.
4. Właściwości dodatkowe (*)
Na tej zakładce definiujemy dodatkowe właściwości użytkownika, które dokładnie pasują do sprzedanego towaru. Ilość oraz występowanie powyższych właściwości jest ograniczona w zależności od wersji programu. Zobacz dostępne wersje...

Użytkownik wprowadzając właściwość może dowolnie wprowadzać jej nazwę (np. waga, rozmiar, ciężar, producent ...), występowanie (zestawienie tabelaryczne/ szczegółowe lub żadne) oraz styl wyświetlania (czcionka, pogrubiona, pochyła, podkreślona, przekreślona).

Opis tabeli definiującej właściwości

  • Nazwa - nazwa właściwości wyświetlana w generowanym sklepie (np. waga, rozmiar, ciężar, producent ...),
  • Widoczność - określamy miejsce wyświetlania właściwości. Dostępne wartości:
    • Szczegóły i zestawienie - zdefiniowana właściwość będzie wyświetlana zarówno w zestawieniu tabelarycznym jak i szczegółowym produktu,
    • Tylko szczegóły - zdefiniowana właściwość będzie wyświetlana tylko w zestawieniu szczegółowym danego produktu,
    • Tylko zestawienie - zdefiniowana właściwość będzie wyświetlana tylko w zestawieniu tabelarycznym zawierającym produkty w podziale na kategorie,
    • Nigdzie - zdefiniowana właściwość nie będzie wyświetlana. Uwaga: Typ ten jest pomocny gdy wprowadziliśmy dane dla kategorii i bez utraty tych informacji chcemy sprawdzić jak wygląda sklep gdy powyższe wartości nie są wyświetlane.
  • B - podczas wyświetlania właściwości będzie używana czcionka pogrubiona,
  • I - podczas wyświetlania właściwości będzie używana czcionka pochyła,
  • U - podczas wyświetlania właściwości będzie używana czcionka zawierająca podkreślone znaki,
  • S - podczas wyświetlania właściwości będzie używana czcionka zawierająca przekreślone znaki.

Po zdefiniowaniu własnych właściwości produktu, użytkownik w celu dokładnego dopasowania wyglądu generowanego sklepu, powinien określić kolejność wyświetlania kategorii.
5. Kolejność (*)
Zakładka ta pozwala dopasować kolejność wyświetlania kategorii (zarówno systemowych jak i też użytkownika) do wymogów konkretnego zastosowania. Występuje ona tylko wtedy gdy wersja programu obsługuje właściwości użytkownika.

Zakładka ta jest podzielona na dwie części. W pierwszej z nich użytkownik określa kolejność wyświetlania właściwości w zestawieniu tabelarycznym (zestawienie zawierające produkty z całej kategorii), natomiast w drugiej części okna określany jest sposób wyświetlania właściwości w zestawieniu szczegółowym produktu. Uwaga: Kolejności powyższe ustawia się przez przeciąganie pól zawierających kolejne cyfry oznaczające numer porządkowy występowania danej właściwości

6. Promocje (*)
Zakładka ta umożliwia definiowanie wszelkich ustawień związanych z obsługą promocji i składa się z następujących części:
  • Definicje nazw promocji - tutaj definiujemy jakie nazwy mają być widoczne przy różnych typach promocji. Dostępne typy promocji:
    • Super oferta - nazwa dla produktów w promocji typu 'super oferta', tzn. dla produktów wyświetlanych w panelu promocyjnym we wszystkich kategoriach i szczegółach wszystkich pozycji.
    • Promocja - nazwa dla produktów umieszczanych w 'normalnej' promocji, tzn. dla produktów umieszczanych pod 'Super ofertą' i w panelu promocyjnym zawierającym tylko produkty z danej kategorii lub także z kategorii nadrzędnych (zależne od ustawień produktu).
  • Definicje nazw produktów - tutaj definiujemy nazwy właściwości wyświetlanych przy promowanych produktach. Dostępne ustawienia:
    • Stara cena - nazwa, która pojawia się w panelu promocyjnym jako stara cena przed promocją. Przykładowo może to być Stara cena, Cena bez promocji...
    • Cena promocyjna - nazwa, która pojawia się w panelu promocyjnym jako nowa cena po uwzględnieniu promocji. Przykładowo może to być Cena promocyjna, Nowa cena...
    • 'przycisk dodawania do koszyka' - zaznaczenie tej opcji powoduje, że pod produktem generowany jest przycisk dodawania do koszyka, przez co użytkownik bezpośrednio z panelu promocyjnego może dodawać towar.
  • Zdjęcia promowanych produktów - w tym miejscu definiujemy rozmiar i miejsce skąd pobierać zdjęcia promowanych produktów. Dostępne ustawienia:
    • 'powiększaj zdjęcia do maksymalnego rozmiaru' - zaznaczenie tej opcji powoduje, że zdjęcia mieszczące się w wymiarach przewidzianych na zdjęcie promocyjne są powiększane do rozmiaru maksymalnego..
    • 'stały rozmiar widoku zdjęcia' - zaznaczenie tej opcji powoduje, że zdjęcia nie mieszczące się w wymiarach przewidzianych na zdjęcie promocyjne są pomniejszane tak aby mieściły się w tych wymiarach. Włączenie tej opcji jest zalecane.
    • 'pobierz zdjęcie z produktu gdy nie ma zdjęcia promocyjnego' - zaznaczenie tej opcji powoduje, że jeśli produkt nie ma zdefiniowanego specjalnego zdjęcia przeznaczonego specjalnie na promocje, to o ile jest zdefiniowane zdjęcie główne produktu to ono pokaże się w panelu promocyjnym.
    • Wysokość i Szerokość - definicja maksymalnych rozmiarów zdjęcia promocyjnego.

(*) - oznacza, że opcje te występują tylko w niektórych wersjach programu. { Szczegółowy opis funkcjonalności z podziałem na wersje…}


Ustawienia generowanej strony WWW

Okno (Ustawienia -> Strona…) to służy do określenia wyglądu generowanego sklepu internetowego.
1. Zakładka Wygląd
Tutaj decydujemy się jaki schemat wyglądu wygenerowanego sklepu nas interesuje. Dostępne schematy:
  • niebieski,

  • zielony.
2. Zakładka Strona główna
W tym miejscu definiujemy jakie informacje są wyświetlane na stronie głównej generowanego sklepu.

Dostępne ustawienia:
  • Nazwa firmy – nazwa sklepu (firmy), która pojawi się na pasku tytułowym przeglądarki oraz na stronie głównej sklepu,
  • Logo – logo firmy, które pojawia się pod nazwą sklepu na stronie głównej, (uwaga: dodanie loga firmy generuje kody HTML, który wstawiany jest do pola Opis. Aby usunąć logo firmy, które zostało dodane należy usunąć wygenerowany automatycznie kod HTML).
  • Opis – informacja o sklepie, która chcesz aby pojawiała się na stronie głównej. Ponieważ wstawiany tutaj tekst może zawierać znaczniki HTML to można stworzyć unikalny wygląd strony głównej.
3. Zakładka Nagłówek strony
W tym miejscu definiujemy czy na każdej stronie naszego sklepu będzie wyświetlany nagłówek (np. logo firmy).

Dostępne ustawienia:
  • ‘pokazuj nagłówek strony’ – gdy opcja ta jest włączona to generowany sklep będzie zawierał nagłówek z ustawieniami, które użytkownik zdefiniuje poniżej.
  • Szczegóły nagłówka strony – tutaj definiujemy szczegółowy wygląd strony przy pomocy następujących opcji:
    • Wysokość nagłówka – określamy jakiej wielkości (w pikselach) ma być nagłówek,
    • Tekst HTML – tekst wprowadzony tutaj znajdzie się w nagłówku sklepu. Uwaga: Informacje wprowadzone tutaj są automatycznie środkowane na stronie.
    • Dodaj zdjęcie – jeśli chcemy aby nagłówek zawierał zdjęcie to po wybraniu tego przycisku, a następnie wybraniu zdjęcia zostanie wstawiony odpowiedni kod HTML wyświetlający to zdjęcie oraz zostanie ono przekopiowane do katalogu projektu.
4. Zakładka Szczegóły pozycji
Zakładka ta służy do określenia w jaki sposób mają być wyświetlane produkty.

Dostępne opcje ustawiające wygląd:
  • ‘wyświetl szczegóły pozycji w nowym oknie’ – jeśli ta opcja jest włączona to po naciśnięciu linku na produkcie informacja szczegółowa pojawia się w nowym oknie. Gdy wyłączona to zamiast listy ze wszystkimi produktami danej kategorii pojawia się szczegółowa informacja o produkcie.

    Gdy włączona jest opcja ‘wyświetl szczegóły pozycji w nowym oknie’ to użytkownik musi zdefiniować własny rozmiar nowo otwieranego okna ze szczegółami produktu. Służą do tego opcje Szerokość okna i Wysokość okna.

    Ponadto do każdego produktu istnieje możliwość dodania zdjęcia oraz w razie potrzeby ujednolicenia wyglądu - odpowiedniego przeskalowania.

    Opcje ustawiające rozmiar zdjęć:

    • ‘zachowaj oryginalną wielkość’ – gdy opcja ta jest włączona to zdjęcie nie podlega procesowi skalowania i jest prezentowane w oryginalnej wielkości. Gdy opcja jest wyłączona możliwe jest:
      • zmniejszanie rozmiaru tylko gdy zdjęcie jest za duże – należy włączyć opcję ‘skaluj tylko gdy zdjęcie jest zbyt duże’ oraz podać rozmiary jaki maksymalny rozmiar zdjęcia będzie wyświetlany,
      • skalowanie zdjęcie do podanego rozmiaru – należy wyłączyć opcję ‘skaluj tylko gdy zdjęcie jest zbyt duże’ oraz podać docelowe rozmiary zdjęcia.

    Dodatkowo na tej zakładce w sekcji 'Opis w przypadku gdy produkt jest niedostępny w sprzedaży' definiujemy opis jaki ma pojawiać się w zestawieniu szczegółowym gdy produkt jest chwilowo niedostępny.

    • 'Tytuł' - nagłówek informacji o braku produktu,
    • 'Opis' - opis informacji o braku produktu.
5. Zakładka Kontakt
Tutaj definiujemy dane adresowe naszego sklepu wyświetlane potem po wybraniu strony Kontakt z menu głównego. Ponadto w tym miejscu definiujemy na jaki adres email będą przesyłane zamówienia klientów sklepu. (opcja Adres email na który przesyłać zamówienia klientów)

Aby włączyć generowanie i wyświetlanie strony z kontaktami zaznacz opcję 'pokazuj stronę z kotanktami'. Gdy opcja ta jest wyłączona to strona ta zarówno nie jest generowana jak i też nie pokazuje się w menu.

Opis uzupełniania danych kontaktowych:

Dane kontaktowe składają się z dwóch kolumn oraz dowolnej ilości wierszy.

Aby uniezależnić się od tego, że dane kontaktowe mogą być różnego typu to pola składowe kontaktów nazywają się Kolumna 1 i Kolumna 2. Ponadto istnieje możliwość zdefiniowania odnośnika do pola Kolumna 2. Jeśli wybierzemy opcję email to wartość w tym polu traktowana jest jako adres poczty elektronicznej, przy czym rzeczywisty adres email wpiszemy w polu Adres (pole to pojawi się po wyborze typu e-mail). Podobnie system zachowa się w przypadku gdy wprowadzaną informacja będzie adres strony WWW - opcja www. Dodatkowo aby dopasować wyglą do własnych potrzeb można sformatować wprowadzony tekst w polu Kolumna 1 przez wybranie stylu pogrubionego (opcja pogrubienie) i/lub pochyłego (opcja kursywa).

Aby jeszcze bardziej uelastycznić wygląd strony Kontakty generowany jest kod HTML, który to w rzeczywistości jest wyświetlany w przeglądarce - kod ten można edytować według własnych potrzeb.

Przykłady:

  1. Aby dodać następującą informację
    Adresy kontaktowe

    Należy w polu Kolumna 1 wpisać wartość Adresy kontaktowe, natomiast pole Kolumna 2 zostawić puste a następnie nacisnąć przycisk Dodaj.

  2. Aby dodać
    Dział sprzedaży Jan Kowalski

    Przy czym po kliknięciu na Jan Kowalski ma otworzyć się okno umożliwiające wysłanie maila na adres janKowalski@firma.pl, należy w polu Kolumna 1 wpisać Dział sprzedaży, w polu Kolumna 2 wpisać Jan Kowalski, następnie należy zaznaczyć opcję email i w polu edycyjnym, które pojawi się po wybraniu tej opcji wpisać adres mailowy janKowalski@firma.pl. Na sam koniec należy wybrać przycisk Dodaj.

  3. Aby dodać
    Anna Nowak

    Należy w polu Kolumna 1 nic nie wpisać, w polu Kolumna 2 wpisać Anna Nowak a następnie nacisnąć przycisk Dodaj.
6. Zakładka Inne
Na tej zakładce definiujemy inne ustawienia generowanego sklepu.

Opcje dotyczące wyświetlania listy podkategorii:

  • 'pokazuj listę podkategorii' - włączenie tej opcji powoduje generowanie zestawienia z podkategoriami danej kategorii. Ostateczne miejsce wyświetlenia tego zestawienia zależy od poniższych opcji:
    • 'także na stronie głównej' - zestawienie generowane jest także na stronie głównej sklepu,
    • 'tylko gdy kategoria nie zawiera produktów' - zestawienie generowane jest tylko wtedy gdy dana kategoria nie zawiera żadnych produktów.


Tworzenie nowego projektu

Aby utworzyć nowy projekt należy wybrać z menu opcję Projekt -> Nowy...

Następnie w poniższym oknie wstawiamy nazwę projektu,

a potem w miejscu wskazanym strzałką wpisujemy nazwę katalogu w którym ma być zapisany projekt. (Uwaga: Zaleca się aby ten katalog był podkatalogiem w którym znajduje się aplikacja)

Uwaga: Utworzenie nowego projektu nie zapisuje jakichkolwiek informacji, lecz tworzy tylko katalog w którym przechowywane będą wszelkie ustawienia oraz nadaje nazwę aktualnemu projektowi.

Aby potem zapamiętać ustawienia należy wybrać opcję Projekt -> Zapisz (Jeśli chcemy dokonać zapisu w innym katalogu niż zostało to ustalone wcześniej wybieramy Projekt -> Zapisz jako ...).


Otwieranie istniejącego projektu

Aby otworzyć istniejący projekt należy wybrać z menu Projekt opcję Otwórz…, a następnie wskazać katalog w którym znajdują się poprzednio zapisane informacje o sklepie internetowym.


Zapis istniejącego projektu

Aby zapisać bieżący projekt w nowym katalogu należy z menu Projekt wybrać opcję Zapisz jako…, a następnie w oknie dialogowym które się wyświetli w miejscu wskazanym strzałką, wpisać katalog gdzie ma być przechowywany projekt.

Zapis projektu do aktualnego katalogu roboczego jest możliwy po wybraniu opcji Projekt -> Zapisz, lub też po naciśnięciu skrótu klawiszowego CTRL+S.

Uwaga: Nie jest możliwy zapis projektu do katalogu głównego aplikacji oraz do podkatalogu template, który zawiera szablony nowo tworzonych sklepów internetowych.


Tworzenie sklepu - instrukcja krok po kroku

Poniższa instrukcja zawiera opis krok po kroku jak najszybciej utworzyć własny sklep internetowy.

  1. Po uruchomieniu programu wybieramy tworzenie nowego projektu (z górnego menu należy wybrać Projekt -> Nowy...). Więcej...
  2. Zdecyduj się na schemat wyglądu sklepu oraz uzupełnij dane podstawowe, takie jak strona główna, logo. (z górnego menu należy wybrać Ustawienia -> Strona ... ). Więcej…
  3. Wprowadź nazwę dodatkowego atrybutu produktu (domyślnie Producent), który będzie odpowiedni do sprzedawanego asortymentu. (jeśli chcesz zmienić wartość domyślną to z górnego menu należy wybrać Ustawienia ->Projekt …). Więcej…
  4. (*) Zdecyduj, które atrybut produktu mają być niewidoczne (domyślnie widoczne są wszystkie). Więcej...
  5. (*) Zdefiniuj własne właściwości użytkownika, określ ich miejsce występowania oraz kolejność wyświetlania. Więcej...
  6. Utwórz drzewo kategorii i podkategorii. (oczywiście w przyszłości będzie możliwe dalsze uzupełnienie tych informacji). Więcej…
  7. Dopisz produkty do wprowadzonych wcześniej kategorii. (produkt dodawany jest do kategorii, która aktualnie wybrana jest w panelu z kategoriami). Więcej…
  8. Ustaw informacje dotyczące serwera na którym ma umieszczony być sklep. (ważne w przypadku gdy chcemy aby program sam wysłał sklep na serwer WWW). Więcej…
  9. Zapisz informacje które do tej pory wprowadziłeś w katalogu wybranym w punkcie 1 (z górnego menu wybierz Projekt -> Zapisz...). Więcej… (Poniższy krok jest konieczny aby prawidłowo wygenerować sklep).
  10. Wygeneruj sklep internetowy. Więcej...
  11. Sprawdź wygląd sklepu i ewentualnie wprowadź poprawki. Więcej… (Jeśli zdecydowałeś się poprawiać dane to pamiętaj o tym, że przed wygenerowaniem sklepu należy najpierw zapisać informacje – punkt 9).
  12. Jeśli wygląd sklepu jest satysfakcjonujący to można wysłać go na serwer WWW. Więcej…

(*) - oznacza, że opcje te występują tylko w niektórych wersjach. { Szczegółowy opis funkcjonalności z podziałem na wersje…}


Wysyłanie sklepu na serwer WWW - instrukcja krok po kroku

Poniższa instrukcja zawiera dokładnie opisane kroki jakie należy wykonać aby wysłać wygenerowaną stronę WWW na zdalny serwer przy pomocy protokołu FTP (o ile dostawca internetowy daje taką możliwość).

Uwaga: Jeśli wysyłanie strony WWW nie jest dostępne przez serwer FTP to należy postępować zgodnie z instrukcją udostępnioną przez dostawcę internetowego opisującą sposób wysyłania stron WWW na serwer. Przy czym należy pamiętać, że wygenerowany sklep dostępny jest w podkatalogu html projektu.

Wysyłanie wygenerowanego sklepu na serwer FTP:

  1. Ustaw parametry serwera w oknie konfiguracyjnym (zakładka ‘Parametry serwera’ dostępna po wybraniu z menu okna konfiguracyjnego projektu – z górnego menu należy wybrać Ustawienia -> Projekt... ). Więcej…
  2. Upewnij się, że sklep który chcesz wysłać na serwer został wcześniej wygenerowany. Można to zrobić np. przez wybranie z okna głównego przycisku [image] - jeśli sklep został wygenerowany to zostanie on wyświetlony w przeglądarce.
  3. Wyślij sklep na serwer FTP, który zdefiniowałeś w kroku nr 1 – przycisk [image].
    Uwaga:
    1. Proszę czytać komunikaty, które pojawiają się podczas łączenia z serwerem.
    2. Jeśli podczas wysyłania pojawi się okno ponownie pytające o nazwę serwera, użytkownika i hasło tzn. że prawdopodobnie przynajmniej jeden z tych parametrów został podany nieprawidłowo, gdyż serwer zdalny nie akceptuje wprowadzonych informacji (szczegółowe informacje w oknie z logiem z serwera). W oknie tym można skorygować parametry połączenia, a następnie ponownie spróbować wysłać wygenerowany sklep. (Uwaga: skorygowane parametry nie są zapamiętywane na stałe w aplikacji, aby zmiany zostały zapisane należy dokonać poprawki w oknie opisanym w pkt. 1)


Szczegółowa funkcjonalność programu w zależności od wersji programu

Wersja

Funkcja

Demo Standard Plus
Dowolna ilość kategorii i podkategorii oraz dowolny poziom zagłębień
Dodawanie i wyświetlanie opisu kategorii oraz generowanie listy streszczenia podkategorii
Nieograniczona ilość produktów w każdej z kategorii | max 10
Podstawowe atrybuty przypisane do każdego produktu:
  • ID (generowane automatycznie)
  • Nazwa produktu
  • Kategoria produktu
  • Pole dodatkowe – zawartość i nazwa definiowana przez użytkownika
  • Cena
  • Zdjęcie (można zdefiniować wielkości do jakich mają być skalowane zdjęcia produktów)
  • Opis
Możliwość wyłączania dostępności produktu do sprzedaży
Obsługa promocji
Generowania własnej strony głównej (wstawianie loga firmy oraz dowolnego tekstu – dozwolone, ale nie wymagane, formatowanie przy pomocy języka HTML)
Ilość własnych definiowanych atrybutów produktu (np. waga, rozmiar) | 1 | 1 | 100
Wybór miejsca (zestawienie tabelaryczne/szczegółowe/oba zestawienia) oraz kolejności wyświetlania i wyrównywania atrybutów użytkownika na wygenerowanej stronie
Przypisanie atrybutów produktu do kategorii (każda kategoria może mieć własne niezależne atrybuty produktu)
Różne szablony generowanego sklepu internetowego
Prezentacja towaru w postaci tabelarycznej (dla całej kategorii) oraz po wybraniu produktu informacji szczegółowej
Dwie możliwości wyświetlania informacji szczegółowych produktu (w nowym oknie/ w istniejącym oknie)
Wybór kolejności sortowania produktów w zestawieniu tabelarycznym
Generowania strony z danymi kontaktowymi firmy (telefony, maile, strony WWW)
Wysyłanie wygenerowanej strony na serwer WWW przy pomocy wbudowanego klienta FTP
Prawo do poprawionych wersji przy błędach aplikacji
Roczny abonament na nowe, dodatkowo rozbudowane wersje programu (wersje dla zarejestrowanych użytkowników dostępne przez WWW)
Pakiet wsparcia technicznego (dostępne przez stronę WWW dla zarejestrowanych użytkowników) | 3 miesiące | 1 rok

Uwaga: Wersja demo ponadto nie obsługuje wysyłania zamówień.


Najczęściej zadawane pytania

Strona ta zawiera najczęściej zadawane pytania:

  1. Jakie są ograniczenia wersji demo?

    Wersja demo pozwala wpisywać maksymalnie 10 produktów oraz nie obsługuje wysyłania sklepu na serwer WWW, poza tym nie ma żadnych innych ograniczeń w porównaniu do wersji Standard.

  2. Mam wersję demo aplikacji a chcę zakupić pełną, z kim mam się skontaktować?

    Wszelkie informacje na temat zakupu programu można uzyskac na stronie WWW programu eShopGen pod adresem http://www.eshopgen.art4u.pl/.

  3. Co mam zrobić gdy program nie ma takiej funkcjonalności jakiej dokładnie potrzebuję?

    Proszę o przesłanie swojego zapotrzebowania na adres eshopgen@art4u.pl.

  4. Co zrobić gdy nie znam języka HTML a mam wstawić tekst?

    Używanie języka HTML jest tylko opcjonalną i dodatkową możliwością. Program został zaprojektowany tak, że nawet jeśli nie znasz języka HTML to nic nie stoi na przeszkodzie aby wpisać czysty tekst. Ponadto program sam postara się zastosować odpowiednie style tak aby wygląd wpisanego tekstu jak najbardziej pasował do aktualnie wybranego schematu. Używanie języka HTML daje tylko dodatkową możliwość formatowania tekstu.

  5. Nie znam języka HTML i przy wpisywaniu tekstu dla strony głównej (lub nagłówka) wstawiam znak nowej lini (ENTER) a pomimo tego na wygenerowanej stronie tekst pisany jest w sposób ciągły.

    Ponieważ język HTML nie rozpoznaje kodu klawisza (ENTER) to aby uzyskać przeniesienie tekstu do nowej lini należy wpisać znacznik : <BR>

  6. Jak mogę stworzyć kopię zapasową danych, aby po przypadkowym usunięciu mógł odzyskać informacje?

    Program został tak zaprojektowany, że wystarczy przegrać katalog projektu w inne miejsce (np. na dyskietkę) aby utworzyć kopię zapasową.

  7. Czy można ręcznie (np. przy pomocy notatnika) edytować pliki projektu?

    Sytuacja taka jest teoretycznie dozwolona, przy czym należy przed taką operacją stworzyć kopię katalogu projektu (kopia zapasowa), dopiero potem można edytować dane. Jeżeli po przeprowadzeniu edycji, przy próbie wczytywania projektu program będzie pokazywał komunikaty o błędach, lub też część informacji nie zostanie wczytana, to konieczne będzie odtworzenie projektu z kopii zapasowej.


Wymagania sprzętowe

Program eShopGen został tak zaprojektowany aby wymagania zarówno po stronie serwera WWW jak i komputera przeglądarki były minimalne.

Wymagania serwera WWW:

Tutaj praktycznie jedynym wymaganiem jest aby dostępna była odpowiednia ilość miejsca na dysku, a ta wielkość zależy głównie od ilości i wielkości dołączonych plików graficznych (zdjęć produktów) do projektu.

Wymagania komputera na którym generowany jest sklep internetowy:

  • Windows 98/ME/2000/XP/2003,
  • przeglądarka internetowa,
  • podłączenie do Internetu (aby można było udostępnić klientom wygenerowany sklep).

Wymagania komputera z którego będzie można przeglądać i składać zamówienia:

  • przeglądarka internetowa,
  • podłączenie do Internetu,
  • prawidłowo skonfigurowany klient pocztowy umożliwiający wysyłanie maili.


Dane kontaktowe

Autor | Marcin Ligorowski
Strona WWW programu | http://www.eshopgen.art4u.pl/
email kontaktowy | eshopgen@art4u.pl
Współpraca
Art4U |
 | http://www.art4u.pl/
 | info@art4u.pl
Symcom |
 | http://www.symcom.pl/
 | info@symcom.pl


Warunki licencyjne zależą od posiadanej wersji produktu.

Szczegółowe zapisy znajdują się w pliku license.txt, który umieszczony jest w katalogu głównym aplikacji.